[Network] H3Cスイッチのあれこれ

先日、H3CのS5100を格安でゲットしました。これで、既存のコアL2であるGS916Mをリプレースすることが出来ました。その際、色々知らないことがあったのねーというのがありましたのでネタとして記載をしようと。

DSC_0355

<Management VLANの定義>

どうやらH3CのL2では、Management VLANを明示的に定義しないと、以下エラーを出力して怒られるっぽい。

Vlan-interface must be the same as Management-vlan

というわけで、以下のコマンドで明示的に管理VLANを定義する必要がある。・・・って、Ciscoもそんなルールあったりしたっけ・・・?

management-vlan <VLAN-ID>

<LAGの組み方>

LAGを組む場合、L3スイッチ(S3610)とL2(S5100)とで組み方が微妙に違っていた。

L3の場合:

■グローバルコンフィグでBridge Aggregationグループと言うものを作成する。

interface Bridge-Aggregation1
port link-type trunk
port trunk permit vlan all
port trunk pvid vlan 110

■結合させたいポートをアグリゲーショングループに含めていく

#
interface GigabitEthernet1/1/3
port link-aggregation group 1
#
interface GigabitEthernet1/1/4
port link-aggregation group 1

L2の場合:

■グローバルコンフィグでlink-aggregationグループを作成する。

link-aggregation group 1 mode manual

■結合させたいポートをアグリゲーショングループに含めていく。VLAN設定はポートの設定の中に含まれる形っぽい。

interface GigabitEthernet1/0/23
port link-type trunk
port trunk permit vlan all
port trunk pvid vlan 110
port link-aggregation group 1
#
interface GigabitEthernet1/0/24
port link-type trunk
port trunk permit vlan all
port trunk pvid vlan 110
port link-aggregation group 1

<Hybridモード>

ちなみに、H3Cのスイッチにはポート設定としてAccessモードとTrunkモードに加え、Hybridモードと言うものがあるらしい。こんな風に設定を行ったりしている。

interface GigabitEthernet1/0/1
port link-type hybrid
port hybrid vlan 20 30 100 110 120 499 787 999 tagged
port hybrid vlan 10 untagged
undo port hybrid vlan 1
port hybrid pvid vlan 10

Alliedみたいに、タグ付きとタグなしが混在する場合は、こういう設定になるみたいです。ヤッパリちゃんと勉強したほうがよかったのかなー・・hpのスイッチって。

No tags for this post.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.